Google Safe Browsing API support removed

On version 29 of Qrafter and Qrafter Pro, I had to remove Google Safe Browsing API support, which was responsible for checking malicious URLs in scanned codes. The reason for this is, Google no longer accepts commercial use of its Safe Browsing API by November 11, 2019 and wants all users of it to start using the new Web Risk API, which has very limited free-tier quotas.

That means, if I wanted to continue providing this service using Web Risk API, it would be costing more than 1000 USD per month to me, which is expensive.

Safe Browsing API will continue to be free for non profit organizations and mainstream browsers. So, with the default in app browser change to iOS provided Safari, that I implemented in May 2019, there should be virtually no security risk from known malicious URLs, because iOS will be handling the checks from now on, instead of Qrafter or Qrafter Pro, which will still continue to unfold short URLs and show you the final URL. If you are using Qrafter’s own in app browser, I recommend that you change it to in app Safari from now on. I may need to remove Qrafter’s in app browser altogether in the future for a more secure app experience.